#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\.)\.{2}(?!\.)|\.{4,}"
Local $sString = ""Hello. World."" & @CRLF & _
""Hello.. World.."" & @CRLF & _
""Hello... World..." // this is correct" & @CRLF & _
""Hello.... World...."" & @CRLF & _
""Hello..... World.....""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")