$re = '/(?<!\.)\.{2}(?!\.)|\.{4,}/';
$str = '"Hello. World."
"Hello.. World.."
"Hello... World..." // this is correct
"Hello.... World...."
"Hello..... World....."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);