using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\.)\.{2}(?!\.)|\.{4,}";
string input = @"""Hello. World.""
""Hello.. World..""
""Hello... World..."" // this is correct
""Hello.... World....""
""Hello..... World.....""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}