# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\S++).*\K(?:\R\1(?:\h.*|$))+//gm;t' <<< "john jane
john 123
john jim jane
jane john
jane 123
jane 456
jim
jim 1"