using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S++).*\K(?:\R\1(?:\h.*|$))+";
string substitution = @"";
string input = @"john jane
john 123
john jim jane
jane john
jane 123
jane 456
jim
jim 1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}