# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\S++).*\K(?:\R\1(?:\h.*|$))+"
test_str = ("john jane\n"
"john 123\n"
"john jim jane\n"
"jane john\n"
"jane 123\n"
"jane 456\n"
"jim\n"
"jim 1")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.