package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\([^\\.]*)(?:\..*)?`)
var str = `C:\folder0\myhtml.html`
var substitution = "/$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}