re = /\\([^\\.]*)(?:\..*)?/m
str = 'C:\\folder0\\myhtml.html'
subst = '/$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result