$re = '/\\\\([^\\\\.]*)(?:\..*)?/m';
$str = 'C:\\folder0\\myhtml.html';
$subst = "/$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;