using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^,]*,){1}([^,]*)(,.*)?";
string substitution = @"$2";
string input = @"""A"",""B"",""C"",""D""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}