#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<(?!(?:/\s*)?[a-z]+(?:\s+[^>]*)?/?>)|(?<!<(?:/\s*)?[a-z]+(?:\s+[^>]*)?/?)>"
Local $sString = "<" & @CRLF & _
"text" & @CRLF & _
">" & @CRLF & _
"<ul>" & @CRLF & _
" <li>[Message processing time] < [time to send ack to Azure Service Bus] (about less than 100ms per message)</li>" & @CRLF & _
" <li>[Total process time of a group of messages] < [Message Lock Time] (default: 1 min)<br><b>Strictly REQUIRED</b> to avoid lock loss and messages processed more than one time" & @CRLF & _
" </li>" & @CRLF & _
"</ul>" & @CRLF & _
"<>" & @CRLF & _
"> <" & @CRLF & _
"5 > 3 < 2 > 1" & @CRLF & _
"" & @CRLF & _
"<a href="www.google.com">placeholder!!</a>" & @CRLF & _
"" & @CRLF & _
"<hello >" & @CRLF & _
"< ciao>" & @CRLF & _
"<hello>" & @CRLF & _
"<hello></hello>" & @CRLF & _
"</b>" & @CRLF & _
"< /b>" & @CRLF & _
""
Local $sSubst = "&[gl]t;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)