using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?!(?:/\s*)?[a-z]+(?:\s+[^>]*)?/?>)|(?<!<(?:/\s*)?[a-z]+(?:\s+[^>]*)?/?)>";
string substitution = @"&[gl]t;";
string input = @"<
text
>
<ul>
<li>[Message processing time] < [time to send ack to Azure Service Bus] (about less than 100ms per message)</li>
<li>[Total process time of a group of messages] < [Message Lock Time] (default: 1 min)<br><b>Strictly REQUIRED</b> to avoid lock loss and messages processed more than one time
</li>
</ul>
<>
> <
5 > 3 < 2 > 1
<a href=""www.google.com"">placeholder!!</a>
<hello >
< ciao>
<hello>
<hello></hello>
</b>
< /b>
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}