import Foundation
let pattern = #"<(?!(?:/\s*)?[a-z]+(?:\s+[^>]*)?/?>)|(?<!<(?:/\s*)?[a-z]+(?:\s+[^>]*)?/?)>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<
text
>
<ul>
<li>[Message processing time] < [time to send ack to Azure Service Bus] (about less than 100ms per message)</li>
<li>[Total process time of a group of messages] < [Message Lock Time] (default: 1 min)<br><b>Strictly REQUIRED</b> to avoid lock loss and messages processed more than one time
</li>
</ul>
<>
> <
5 > 3 < 2 > 1
<a href="www.google.com">placeholder!!</a>
<hello >
< ciao>
<hello>
<hello></hello>
</b>
< /b>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"&[gl]t;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)