#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\d{2}:\d{2}:\d{2} - (?:\[[^\]]*\] )?)([\w: -]+)"
Local $sString = "INFO: Device 6: Time 20.11.2015 06:28:00 - [Script] FunFehlerButton: Execute [0031 text]" & @CRLF & _
"and " & @CRLF & _
"INFO: Device 0: Time 09.12.2015 03:51:44 - [Replication] FunFehlerButton: Execute" & @CRLF & _
"and " & @CRLF & _
"INFO: Device 6: Time 20.11.2015 06:28:00 - FunFehlerButton: Execute"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")