import re
regex = re.compile(r"(?:\d{2}:\d{2}:\d{2} - (?:\[[^\]]*\] )?)([\w: -]+)")
test_str = ("INFO: Device 6: Time 20.11.2015 06:28:00 - [Script] FunFehlerButton: Execute [0031 text]\n"
"and \n"
"INFO: Device 0: Time 09.12.2015 03:51:44 - [Replication] FunFehlerButton: Execute\n"
"and \n"
"INFO: Device 6: Time 20.11.2015 06:28:00 - FunFehlerButton: Execute")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")