import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^WebServer:.*?endOfLine";
final String string = "amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
+ "WebServerClosed: status 10. S\n"
+ "amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
+ "WebServerClosed: status 10. S\n"
+ "amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
+ "WebServerClosed: status 10. S\n"
+ "WebServer: error 2312. Falha de conexão com o destino. StartLine Lorem ipsum dolor sit amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
+ "WebServerClosed: status 10. Sent Request\n"
+ "amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
+ "WebServerClosed: status 10. S\n"
+ "amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
+ "WebServerClosed: status 10. S\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}