import re
regex = re.compile(r"^WebServer:.*?endOfLine", flags=re.MULTILINE)
test_str = ("amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
"WebServerClosed: status 10. S\n"
"amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
"WebServerClosed: status 10. S\n"
"amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
"WebServerClosed: status 10. S\n"
"WebServer: error 2312. Falha de conexão com o destino. StartLine Lorem ipsum dolor sit amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
"WebServerClosed: status 10. Sent Request\n"
"amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
"WebServerClosed: status 10. S\n"
"amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine\n"
"WebServerClosed: status 10. S\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")