re = /^WebServer:.*?endOfLine/m
str = 'amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine
WebServerClosed: status 10. S
amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine
WebServerClosed: status 10. S
amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine
WebServerClosed: status 10. S
WebServer: error 2312. Falha de conexão com o destino. StartLine Lorem ipsum dolor sit amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine
WebServerClosed: status 10. Sent Request
amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine
WebServerClosed: status 10. S
amet, consectetur adipiscing elit...Lorem ipsum dolor sit amet, consectetur adipiscing elit...step1 endOfLine
WebServerClosed: status 10. S
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end