using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\s*\)|\s+(?=[,)])|(?<=\()\s+|(,),+";
string substitution = @"\1";
string input = @"Te( )st
Test()
Test ()
Test ( )
Test ,,
Test,,
Test , ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}