re = /\(\s*\)|\s+(?=[,)])|(?<=\()\s+|(,),+/m
str = 'Te( )st
Test()
Test ()
Test ( )
Test ,,
Test,,
Test , '
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result