$re = '/\(\s*\)|\s+(?=[,)])|(?<=\()\s+|(,),+/m';
$str = 'Te( )st
Test()
Test ()
Test ( )
Test ,,
Test,,
Test , ';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;