using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<table>.*?(<tr>.*?(<td>(.*?)</td>).*?</tr>).*?</table>";
string input = @"<table>|<tr>[<td>#VALOR#</td>]</tr>|</table>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}