re = /<table>.*?(<tr>.*?(<td>(.*?)<\/td>).*?<\/tr>).*?<\/table>/
str = '<table>|<tr>[<td>#VALOR#</td>]</tr>|</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end