package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<table>.*?(<tr>.*?(<td>(.*?)</td>).*?</tr>).*?</table>`)
var str = `<table>|<tr>[<td>#VALOR#</td>]</tr>|</table>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}