# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)&f/$1/gm;t' <<< "Hello &f are &f you &f here?"