$re = '/(.*)&f/m';
$str = 'Hello &f are &f you &f here?';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;