use strict;
my $str = 'Hello &f are &f you &f here?';
my $regex = qr/(.*)&f/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";