package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/([^\.]+)\.domain\.com\/([^#]+)([#\d]+)`)
var str = `De:
http://carros.domain.com/visualizar#123
http://casas.domain.com/visualizar#345
http://aps.domain.com/visualizar#567
Para:
http://domain.com/carros/ver#123
http://domain.com/casas/ver#345
http://domain.com/aps/ver#567
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}