$re = '/https?:\/\/([^\.]+)\.domain\.com\/([^#]+)([#\d]+)/';
$str = 'De:
http://carros.domain.com/visualizar#123
http://casas.domain.com/visualizar#345
http://aps.domain.com/visualizar#567
Para:
http://domain.com/carros/ver#123
http://domain.com/casas/ver#345
http://domain.com/aps/ver#567
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);