// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?:\/\/([^\.]+)\.domain\.com\/([^#]+)([#\d]+)").unwrap();
let string = "De:
http://carros.domain.com/visualizar#123
http://casas.domain.com/visualizar#345
http://aps.domain.com/visualizar#567
Para:
http://domain.com/carros/ver#123
http://domain.com/casas/ver#345
http://domain.com/aps/ver#567
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}