$re = '/^.*?(\S*)\({1}.*?ref\s*SqlConnection/s';
$str = ' public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{
}
public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);