import Foundation
let pattern = #"^.*?(\S*)\({1}.*?ref\s*SqlConnection"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{
}
public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}