# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?(\S*)\({1}.*?ref\s*SqlConnection"
test_str = (" public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,\n"
" string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,\n"
" string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,\n"
" //string Company, string NoteCategory, ref OracleConnection Connection)\n"
" string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)\n"
" {\n"
"}\n\n"
" public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,\n"
" string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,\n"
" string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,\n"
" //string Company, string NoteCategory, ref OracleConnection Connection)\n"
" string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)\n"
" {\n"
"}")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.