using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\>)([^<>]+)(?=\<)";
string input = @"<p alt=""100"">100</p>
<img src=""100.jpg"">100</ing>
<span alt=""tel:100"">100</span>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}