$re = '/(?!\>)([^<>]+)(?=\<)/';
$str = '<p alt="100">100</p>
<img src="100.jpg">100</ing>
<span alt="tel:100">100</span>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);