import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\>)([^<>]+)(?=\\<)";
final String string = "<p alt=\"100\">100</p>\n"
+ "<img src=\"100.jpg\">100</ing>\n"
+ "<span alt=\"tel:100\">100</span>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}