using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-*?([\w\.]{1,100}@\w[\w\-]+\.+com|biz|us|bd)-*?";
string input = @"<html>
<body>
<p>aaa@example.jpg</p>
<p>--bbb@example.com--</p>
<p>ccc@example.com--</p>
<p>--ddd@example.com</p>
222@example.jpg.com
</body>
</html>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}