import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-*?([\\w\\.]{1,100}@\\w[\\w\\-]+\\.+com|biz|us|bd)-*?";
final String string = "<html>\n"
+ " <body>\n"
+ " <p>aaa@example.jpg</p>\n"
+ " <p>--bbb@example.com--</p>\n"
+ " <p>ccc@example.com--</p>\n"
+ " <p>--ddd@example.com</p>\n"
+ " 222@example.jpg.com\n\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}