import re
regex = re.compile(r"-*?([\w\.]{1,100}@\w[\w\-]+\.+com|biz|us|bd)-*?", flags=re.MULTILINE)
test_str = ("<html>\n"
" <body>\n"
" <p>aaa@example.jpg</p>\n"
" <p>--bbb@example.com--</p>\n"
" <p>ccc@example.com--</p>\n"
" <p>--ddd@example.com</p>\n"
" 222@example.jpg.com\n\n"
"</body>\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")