$re = '/^(?!\$transation\[\d+\]=\'[^\']*\';$).*$/m';
$str = '$transation[123456]=\'Table9912333\';
$transation[123457]=\'Table8123321\';
$transation[123458]=\'Chair0123334\';
$transation[123458]=\'Chair0123334\'sdfds;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);