re = /^(?!\$transation\[\d+\]='[^']*';$).*$/m
str = '$transation[123456]=\'Table9912333\';
$transation[123457]=\'Table8123321\';
$transation[123458]=\'Chair0123334\';
$transation[123458]=\'Chair0123334\'sdfds;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end