using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Profile/(\d+) # Profile followed by digits
(?:(?!Allan)[\S\s])+ # any character
Allan # Allan literally
(?:(?!AddAnswer)[\S\s])+ # any character
AddAnswer(\d+) # AddAnswer, followed by digits";
string input = @"<h4><a href=""/Profile/23423423423.html"">@@@@@@</a> </h4> said12:49:32
</div>
<a href=""javascript:void(0)"" onclick=""replyAnswer(@@@@@@@@@@,'GET','');"" class=""reportLink"">
report </a>
</div>
<div class=""details"">
<p class=""content"">
Hi there, Allan.
</p>
<div id=""AddAnswer123456""></div>
<h4><a href=""/Profile/23423423423.html"">@@@@@@</a> </h4> said12:49:32
</div>
<a href=""javascript:void(0)"" onclick=""replyAnswer(@@@@@@@@@@,'GET','');"" class=""reportLink"">
report </a>
</div>
<div class=""details"">
<p class=""content"">
Hi there, Allan.
</p>
<div id=""AddAnswer123452343232233""></div>
<h4><a href=""/Profile/23423423423.html"">@@@@@@</a> </h4> said12:49:32
</div>
<a href=""javascript:void(0)"" onclick=""replyAnswer(@@@@@@@@@@,'GET','');"" class=""reportLink"">
report </a>
</div>
<div class=""details"">
<p class=""content"">
Hi there, Allan.
</p>
<div id=""AddAnswer1234523453245""></div>
<h4><a href=""/Profile/23423423423.html"">@@@@@@</a> </h4> said12:49:32
</div>
<a href=""javascript:void(0)"" onclick=""replyAnswer(@@@@@@@@@@,'GET','');"" class=""reportLink"">
report </a>
</div>
<div class=""details"">
<p class=""content"">
Hi there, Allan.
</p>
<div id=""AddAnswer1234523453245""></div>
<h4><a href=""/Profile/23423423423.html"">@@@@@@</a> </h4> said12:49:32
</div>
<a href=""javascript:void(0)"" onclick=""replyAnswer(@@@@@@@@@@,'GET','');"" class=""reportLink"">
report </a>
</div>
<div class=""details"">
<p class=""content"">
Hi there, Allan.
</p>
<div id=""AddAnswer1234523453245""></div>";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}