import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Profile/(\\d+) # Profile followed by digits\n"
+ "(?:(?!Allan)[\\S\\s])+ # any character\n"
+ "Allan # Allan literally\n"
+ "(?:(?!AddAnswer)[\\S\\s])+ # any character\n"
+ "AddAnswer(\\d+) # AddAnswer, followed by digits";
final String string = "<h4><a href=\"/Profile/23423423423.html\">@@@@@@</a> </h4> said12:49:32\n"
+ " </div>\n\n"
+ " <a href=\"javascript:void(0)\" onclick=\"replyAnswer(@@@@@@@@@@,'GET','');\" class=\"reportLink\">\n"
+ " report </a>\n"
+ " </div>\n\n"
+ " <div class=\"details\">\n"
+ " <p class=\"content\">\n\n\n"
+ " Hi there, Allan.\n\n\n\n"
+ " </p>\n\n"
+ " <div id=\"AddAnswer123456\"></div>\n"
+ "<h4><a href=\"/Profile/23423423423.html\">@@@@@@</a> </h4> said12:49:32\n"
+ " </div>\n\n"
+ " <a href=\"javascript:void(0)\" onclick=\"replyAnswer(@@@@@@@@@@,'GET','');\" class=\"reportLink\">\n"
+ " report </a>\n"
+ " </div>\n\n"
+ " <div class=\"details\">\n"
+ " <p class=\"content\">\n\n\n"
+ " Hi there, Allan.\n\n\n\n"
+ " </p>\n\n"
+ " <div id=\"AddAnswer123452343232233\"></div>\n"
+ "<h4><a href=\"/Profile/23423423423.html\">@@@@@@</a> </h4> said12:49:32\n"
+ " </div>\n\n"
+ " <a href=\"javascript:void(0)\" onclick=\"replyAnswer(@@@@@@@@@@,'GET','');\" class=\"reportLink\">\n"
+ " report </a>\n"
+ " </div>\n\n"
+ " <div class=\"details\">\n"
+ " <p class=\"content\">\n\n\n"
+ " Hi there, Allan.\n\n\n\n"
+ " </p>\n\n"
+ " <div id=\"AddAnswer1234523453245\"></div>\n"
+ "<h4><a href=\"/Profile/23423423423.html\">@@@@@@</a> </h4> said12:49:32\n"
+ " </div>\n\n"
+ " <a href=\"javascript:void(0)\" onclick=\"replyAnswer(@@@@@@@@@@,'GET','');\" class=\"reportLink\">\n"
+ " report </a>\n"
+ " </div>\n\n"
+ " <div class=\"details\">\n"
+ " <p class=\"content\">\n\n\n"
+ " Hi there, Allan.\n\n\n\n"
+ " </p>\n\n"
+ " <div id=\"AddAnswer1234523453245\"></div>\n"
+ "<h4><a href=\"/Profile/23423423423.html\">@@@@@@</a> </h4> said12:49:32\n"
+ " </div>\n\n"
+ " <a href=\"javascript:void(0)\" onclick=\"replyAnswer(@@@@@@@@@@,'GET','');\" class=\"reportLink\">\n"
+ " report </a>\n"
+ " </div>\n\n"
+ " <div class=\"details\">\n"
+ " <p class=\"content\">\n\n\n"
+ " Hi there, Allan.\n\n\n\n"
+ " </p>\n\n"
+ " <div id=\"AddAnswer1234523453245\"></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}