use strict;
my $str = '<h4><a href="/Profile/23423423423.html">@@@@@@</a> </h4> said12:49:32
</div>
<a href="javascript:void(0)" onclick="replyAnswer(@@@@@@@@@@,\'GET\',\'\');" class="reportLink">
report </a>
</div>
<div class="details">
<p class="content">
Hi there, Allan.
</p>
<div id="AddAnswer123456"></div>
<h4><a href="/Profile/23423423423.html">@@@@@@</a> </h4> said12:49:32
</div>
<a href="javascript:void(0)" onclick="replyAnswer(@@@@@@@@@@,\'GET\',\'\');" class="reportLink">
report </a>
</div>
<div class="details">
<p class="content">
Hi there, Allan.
</p>
<div id="AddAnswer123452343232233"></div>
<h4><a href="/Profile/23423423423.html">@@@@@@</a> </h4> said12:49:32
</div>
<a href="javascript:void(0)" onclick="replyAnswer(@@@@@@@@@@,\'GET\',\'\');" class="reportLink">
report </a>
</div>
<div class="details">
<p class="content">
Hi there, Allan.
</p>
<div id="AddAnswer1234523453245"></div>
<h4><a href="/Profile/23423423423.html">@@@@@@</a> </h4> said12:49:32
</div>
<a href="javascript:void(0)" onclick="replyAnswer(@@@@@@@@@@,\'GET\',\'\');" class="reportLink">
report </a>
</div>
<div class="details">
<p class="content">
Hi there, Allan.
</p>
<div id="AddAnswer1234523453245"></div>
<h4><a href="/Profile/23423423423.html">@@@@@@</a> </h4> said12:49:32
</div>
<a href="javascript:void(0)" onclick="replyAnswer(@@@@@@@@@@,\'GET\',\'\');" class="reportLink">
report </a>
</div>
<div class="details">
<p class="content">
Hi there, Allan.
</p>
<div id="AddAnswer1234523453245"></div>';
my $regex = qr~Profile/(\d+) # Profile followed by digits
(?:(?!Allan)[\S\s])+ # any character
Allan # Allan literally
(?:(?!AddAnswer)[\S\s])+ # any character
AddAnswer(\d+) # AddAnswer, followed by digits~xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}