import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:S|PD|CH|ML|MD|VA|BVI|DB|KD|KE|PW|COL|AD|MET|VP|SI|VR|GAO|LK|RP|PAD|WAN|PWD|PMP|PBR|VN|PPC|NK|K|AH|I|JP|JU|UDZ|CHM|DDN|LN|CL|CLH|DKM|GK|WD|ED|DDK|DLN|DRN|DFD|GZB|DVV|GUR|GGN|ND|HHN|HAS|HYD|HKP|BWF|BBW|BKM|BSN|BL|BIN|ST|KN).*?\\d+\\b";
final String string = "pt paid rs-8488/- remaining amt\n"
+ "Credit Card Sales\n"
+ "ML 2926 VARSHA LAKHANI (AG)\n"
+ "IMRAN KHAN-PW-4798\n"
+ "Deepali Mishra Ah-5564 Tst\n"
+ "MANJU S-11226 T\n"
+ "SNEHA S-16191\n"
+ "SUMIT SETHI AH-5747 AG\n"
+ "SUJATA VORA AH-5361 AG\n"
+ "Deepali Mishra Ah-5564 Tst";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}