import Foundation
let pattern = #"\b(?:S|PD|CH|ML|MD|VA|BVI|DB|KD|KE|PW|COL|AD|MET|VP|SI|VR|GAO|LK|RP|PAD|WAN|PWD|PMP|PBR|VN|PPC|NK|K|AH|I|JP|JU|UDZ|CHM|DDN|LN|CL|CLH|DKM|GK|WD|ED|DDK|DLN|DRN|DFD|GZB|DVV|GUR|GGN|ND|HHN|HAS|HYD|HKP|BWF|BBW|BKM|BSN|BL|BIN|ST|KN).*?\d+\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
pt paid rs-8488/- remaining amt
Credit Card Sales
ML 2926 VARSHA LAKHANI (AG)
IMRAN KHAN-PW-4798
Deepali Mishra Ah-5564 Tst
MANJU S-11226 T
SNEHA S-16191
SUMIT SETHI AH-5747 AG
SUJATA VORA AH-5361 AG
Deepali Mishra Ah-5564 Tst
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)