// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:S|PD|CH|ML|MD|VA|BVI|DB|KD|KE|PW|COL|AD|MET|VP|SI|VR|GAO|LK|RP|PAD|WAN|PWD|PMP|PBR|VN|PPC|NK|K|AH|I|JP|JU|UDZ|CHM|DDN|LN|CL|CLH|DKM|GK|WD|ED|DDK|DLN|DRN|DFD|GZB|DVV|GUR|GGN|ND|HHN|HAS|HYD|HKP|BWF|BBW|BKM|BSN|BL|BIN|ST|KN).*?\d+\b").unwrap();
let string = "pt paid rs-8488/- remaining amt
Credit Card Sales
ML 2926 VARSHA LAKHANI (AG)
IMRAN KHAN-PW-4798
Deepali Mishra Ah-5564 Tst
MANJU S-11226 T
SNEHA S-16191
SUMIT SETHI AH-5747 AG
SUJATA VORA AH-5361 AG
Deepali Mishra Ah-5564 Tst";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}