using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A(?:nt|pple)\sA";
string substitution = @"";
string input = @"Apple Apple";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}