use strict;
my $str = 'Apple Apple';
my $regex = qr/A(?:nt|pple)\sA/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";