#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w*@\w*.\w*)"
Local $sString = "email me! john@smith.com" & @CRLF & _
"e:john@smith.com m:555-555-5555" & @CRLF & _
"john@smith.com--personal email"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")